buggy droid report submission

Discussion and suggestions regarding the site and/or forum.

Moderator: Forum Moderator

Post Reply
Mrtn
Novice Crafter
Posts: 10
Joined: Mon Feb 27, 2017 4:59 pm

buggy droid report submission

Post by Mrtn »

Hello !

I ve searched the forum but did not find a specific info about this.

Some planets are left out on multiplanet resource spawns. Is it a known bug and are there workarounds?

thank you
User avatar
Savacc
Architect & Shipwright Forum Moderator
Posts: 1248
Joined: Mon Mar 26, 2007 9:45 pm
Location: Central Oregon

Re: buggy droid report submission

Post by Savacc »

could you give me some more details?
Which server?
What planets?
Do you mean that you have sent out an ISD and the ISD leaves out some planets, or the ISD lists planets that SWGCraft doesn't?

If you are talking about new planets added on some "custom" servers, then SWGCraft does not have a way to add them for individual server reports, yet. That will take some rewriting of our code and someone willing to do it.
Mrtn
Novice Crafter
Posts: 10
Joined: Mon Feb 27, 2017 4:59 pm

Re: buggy droid report submission

Post by Mrtn »

This bug occurs regularly with me so I thought it might be common to others too.

Today I had 2 new resources that spawned on 8 of 10 planets, however when sending those droid reports, only 7 planets were marked as having thhose resources. This happens with most multiplanet resources on any planet, 1 or 2 of 8 planets are left out.
I submit those mail reports in batches of 10 mails, so with mails for mineral, chemical, gas, water and flora its 5 times 10 mails. Im counting the mails so I dont leave some out by mistake.
So this time I checked the droid reports after updating the site and the information about those missing planets was in the mails, when I updated the specific mails one by one once more, it worked and all 8 planets were marked.
Then I worked through all 50 reports again and submitted them again but only one report each time, but nothing else came up, so Im not sure that sending mails in batches of 10 is the problem.
Since I could not find any specific situation where this occurs I started by disabling all security apps for swgcraft.org and I will see if this changes anything.
User avatar
Savacc
Architect & Shipwright Forum Moderator
Posts: 1248
Joined: Mon Mar 26, 2007 9:45 pm
Location: Central Oregon

Re: buggy droid report submission

Post by Savacc »

is this for Basilisk?

I haven't sent out ISDs since sometime last fall. When I did, I was submitting them through SWGAide.com, so I wouldn't see what you are seeing.

Submitting 1 or 10 reports at a time should not make a difference. I am not surprised you ruled that out. Keep me apprised as to what you find. If there is a "bug" I'll inform Sobuno or Slyvampi.
Mrtn
Novice Crafter
Posts: 10
Joined: Mon Feb 27, 2017 4:59 pm

Re: buggy droid report submission

Post by Mrtn »

yes, Im on basilisk
Tbh I didnt know that swgAide was fixed.
When I gave it a try in 2017 it wouldnt even start and I never got it running properly, but after your recommendation I looked it up again on swgaide.com and am happy to use it now.
Especially sorting through isd reports and marking resources unavailable works like a charm and swgcraft seems to update quickly after you put info on swgaide.com.
I might use the desktop app on swgAide from now on so thank you vm.
User avatar
Savacc
Architect & Shipwright Forum Moderator
Posts: 1248
Joined: Mon Mar 26, 2007 9:45 pm
Location: Central Oregon

Re: buggy droid report submission

Post by Savacc »

Yes, Mr-Miage, who is Solorisjedi here, decided to redo SWGAide and host it on a site he can run. It is basically the same SWGAide that Zimoon wrote, just updated for the Emu and new NGE servers. It updates here hourly. I'm sorry you just got the word. As far as I am concerned, it is a no brainer to use SWGAide.com to update SWGCraft.
Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests