major error in SOAP

Ideas and discussions on third party tools and utilities

Moderator: Forum Moderator

Post Reply
User avatar
Mutt-Li
Novice Crafter
Posts: 45
Joined: Fri Oct 22, 2010 7:06 pm

major error in SOAP

Post by Mutt-Li » Tue Jan 01, 2013 3:31 am

this is the packet being sent

Code: Select all

<?xml version="1.0"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/">
<SOAP-ENV:Body SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:NS2="urn:swgcraft"><NS1:SoapAddAvailability xmlns:NS1="urn:swgcraft"><input href="#1"/></NS1:SoapAddAvailability><NS2:AddAvailabilityInput id="1" xsi:type="NS2:AddAvailabilityInput"><ResourceID xsi:type="xsd:int">1311452</ResourceID>
<Server xsi:type="xsd:int">106</Server>
<Planet xsi:type="xsd:int">9</Planet>
<Login href="#2"/><ProgramInfo href="#3"/></NS2:AddAvailabilityInput><NS2:Login id="2" xsi:type="NS2:Login"><userid xsi:type="xsd:string">9259</userid>
<md5pass xsi:type="xsd:string">c4d60e5d0c0d0a623cdf3b37afba3e55</md5pass>
</NS2:Login><NS2:ProgramInfo id="3" xsi:type="NS2:ProgramInfo"><Name xsi:type="xsd:string">FZ_OCR_Res_Scanner</Name>
<Version xsi:type="xsd:string">1.2.2</Version>
</NS2:ProgramInfo></SOAP-ENV:Body></SOAP-ENV:Envelope>
this is the returned error

Code: Select all

<?xml version="1.0" encoding="ISO-8859-1"?>
<SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
  xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/">
<SOAP-ENV:Body>
<SOAP-ENV:Fault><faultcode xsi:type="xsd:string">SERVER</faultcode>
<faultactor xsi:type="xsd:string"></faultactor><faultstring xsi:type="xsd:string">despawning from wrong planets</faultstring>
<detail><Name xsi:type="xsd:string">FZ_OCR_Res_Scanner</Name>
<Version xsi:type="xsd:string">1.2.2</Version>
</detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>
can someone explain why I'm getting an "despawning from wrong planets" error while performing a "SoapAddAvailability"

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Re: major error in SOAP

Post by Sobuno » Tue Jan 01, 2013 3:51 am

You've banned your program/version combination via http://swgcraft.org/dev/maintain_programs.php

User avatar
Mutt-Li
Novice Crafter
Posts: 45
Joined: Fri Oct 22, 2010 7:06 pm

Re: major error in SOAP

Post by Mutt-Li » Tue Jan 01, 2013 4:16 am

weird, wonder how i found old code,
thanks, that solves the problem,
but you have to admit, the error is weird

just found updated one, (1.2.7) now have to make it compat with SWGEmu

User avatar
Sobuno
Developer
Posts: 2589
Joined: Sun Mar 25, 2007 2:17 am
Contact:

Re: major error in SOAP

Post by Sobuno » Tue Jan 01, 2013 2:12 pm

Mutt-Li wrote:but you have to admit, the error is weird
It's an error message you've written yourself :P

User avatar
Mutt-Li
Novice Crafter
Posts: 45
Joined: Fri Oct 22, 2010 7:06 pm

Re: major error in SOAP

Post by Mutt-Li » Fri Jan 04, 2013 6:00 pm

Sobuno wrote:
Mutt-Li wrote:but you have to admit, the error is weird
It's an error message you've written yourself :P
actually the error message is in the 9th line of the data packet im receiving

Code: Select all

<faultactor xsi:type="xsd:string"></faultactor><faultstring xsi:type="xsd:string">despawning from wrong planets</faultstring>

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests